In this article, I will show you how to monitor how other people are using the internet on the mikrotik router.
Go to "System" > "Logging"
Click on "Actions" tab, put a meaningful name such as "RemoteLog", Choose "remote" option from type.
Remote Address : Use the command "ipconfig /all" in "CMD" command pannel.
Now click on "Rules" tab, choose "firewall" from topics drop-down menu, choose your created action (RemoteLog) from action drop down menu.
By default, the log file will contain the source IP address and the destination IP address. It's hard to determine what those sites are. In this part, I will list the IP addresses corresponding to what websites. You need to use the commands here:
/ip firewall address-list
add address=192.168.1.0/24 list=LAN-IP
First you will name your ip lan block, in this article I named it "LAN-IP", and my local network address is 192.168.1.0/24.
Then create rules to collect server IP addresses of websites like Facebook, YouTube, Tik-Tok. You just need to copy and paste it into the command window in winbox. On the basis of the IP server list received. You will configure it to store everyone's browsing history.
/ip firewall raw
add action=add-dst-to-address-list address-list=Facebook address-list-timeout=12h chain=prerouting comment=Facebook content=.facebook.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Facebook address-list-timeout=12h chain=prerouting content=.facebook.net dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Facebook address-list-timeout=12h chain=prerouting content=fb.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Facebook address-list-timeout=12h chain=prerouting content=.fbcdn.net dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Facebook address-list-timeout=12h chain=prerouting content=.fbsbx.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Facebook address-list-timeout=12h chain=prerouting content=fb.gg dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Facebook address-list-timeout=12h chain=prerouting content=fbwat.ch dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Facebook address-list-timeout=12h chain=prerouting content=messenger.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Facebook address-list-timeout=12h chain=prerouting content=m.me dst-address-list=!LAN-IP src-address-list=LAN-IP
#YouTube
add action=add-dst-to-address-list address-list=YouTube address-list-timeout=12h chain=prerouting comment=YouTube content=.youtube.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=YouTube address-list-timeout=12h chain=prerouting content=.googlevideo.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=YouTube address-list-timeout=12h chain=prerouting content=.ytimg.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=YouTube address-list-timeout=12h chain=prerouting content=.youtu.be dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=YouTube address-list-timeout=12h chain=prerouting content=.youtube.googleapis.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Instagram address-list-timeout=12h chain=prerouting comment=Instagram content=.instagram.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Instagram address-list-timeout=12h chain=prerouting content=.cdninstagram.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Twitter address-list-timeout=12h chain=prerouting comment=Twitter content=twitter.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Twitter address-list-timeout=12h chain=prerouting content=.twitter.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Twitter address-list-timeout=12h chain=prerouting content=.twimg.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Twitter address-list-timeout=12h chain=prerouting content=t.co dst-address-list=!LAN-IP src-address-list=LAN-IP
#Tiktok
add action=add-dst-to-address-list address-list=Tiktok address-list-timeout=12h chain=prerouting comment=Tiktok content=.tiktok.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Tiktok address-list-timeout=12h chain=prerouting content=.tiktokv.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Tiktok address-list-timeout=12h chain=prerouting content=.tiktokcdn.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Tiktok address-list-timeout=12h chain=prerouting content=.byteoversea.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Tiktok address-list-timeout=12h chain=prerouting content=.ibyteimg.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Tiktok address-list-timeout=12h chain=prerouting content=.ibytedtos.com dst-address-list=!LAN-IP src-address-list=LAN-IP
add action=add-dst-to-address-list address-list=Tiktok address-list-timeout=12h chain=prerouting content=.myqcloud.com dst-address-list=!LAN-IP src-address-list=LAN-IP
/ip firewall filter
add action=log chain=forward comment=Facebook connection-state=new dst-address-list=Facebook log-prefix=Facebook src-address-list=LAN-IP
add action=log chain=forward comment=YouTube connection-state=new dst-address-list=YouTube log-prefix=YouTube src-address-list=LAN-IP
add action=log chain=forward comment=Instagram connection-state=new dst-address-list=Instagram log-prefix=Instagram src-address-list=LAN-IP
add action=log chain=forward comment=Twitter connection-state=new dst-address-list=Twitter log-prefix=Twitter src-address-list=LAN-IP
add action=log chain=forward comment=Tiktok connection-state=new dst-address-list=Tiktok log-prefix=Tiktok src-address-list=LAN-IP
Mikrotik syslog Daemon is a windows-based free syslog server that can be used to view and search mikrotik firewall log. You will find a download link here:
MT Syslog Daemon is free to download and can be found in MikroTik Download Page: https://mikrotik.com/archive
Mt syslog Daemon is a lightweight application and does not need to install. Just running this application, firewall log can be viewed and searched. MT Syslog Daemon saves all logs in tmplog file which can be used directly to search any specific log.
Facebook: https://www.facebook.com/routerbest
Twitter: https://twitter.com/routerbestcom
Tags: Mikrotik